I have a bunch of samples, but when I try to play them under Deflemask they either don't play or they sound hideous, even under the highest sample rate. I've tried mono samples and stereo ones. How can I make my samples work?

Examples:

Both of these sound terrible:
https://dl.dropboxusercontent.com/u/411 … (mono).wav
https://dl.dropboxusercontent.com/u/411 … tereo).wav

And here:

This stereo one loads, but is horrendous:
https://dl.dropboxusercontent.com/u/411 … tereo).wav

and the mono one doesn't load at all:
https://dl.dropboxusercontent.com/u/411 … (mono).wav


I have a huge folder full of mono samples that I converted from stereo and they sound wonderful under VGM Music Maker. What gives?

i know nothing about deflemask, but your avatar is the sega channel icon, and im about that.

All the samples that come with it are set to mono, 8000hz, 32-bit float. Try exporting at those settings.

You are exporting them to 44100hz, a non-DefleMask-compatible sampling rate.

Valid DefleMask Sampling rates (as DefleMask shows on samples window) are:
8000hz
11025hz
16000hz
22050hz
32000hz

This sampling rates are the uniques supported to provide a more precise and solid timing in the sound engines for the systems. Also they are the most common frequencies used by lot of games.

Also, they should have 16bits of depth, as the manual says.

VGM Music Maker is loading them fine because it is re-sampling all of your wav files to a compatible sampling rate, but losing lot of data. This was avoided in DefleMask to get more pure sound and because I think that the re-sampling task should be done outside the tracker, to get always better results with an specialized audio editor.

Last edited by Delek (April 13, 2013 12:03 am)

So.... could I just export at the highest 32000hz to be able to smoothly switch between all of the other sample rates under Deflemask?

Edit: Wow... This is just straight up not happening. I'm using Audacity to try to export these things, and changing the sample rate instantly makes any sample slow down and sound terrible. Why does this have to be such a problem?

Last edited by robugaa (April 13, 2013 7:36 pm)

Force the sample rate to change will slow down/speed up the wav, that's right. You have to re-sample or record again the sounds. Search for an option to do re-sampling in Audacity.

You need to use the Project Sample Rate drop-down at the bottom of the window in Audacity, not the Track Properties drop-down in the individual tracks.

Or, if you have a copy of the old sndrec.exe, you could probably use that. smile