So I recently got a GP2X and it came with firmware 3.0 & after using it for awhile the screen started to glitch so i figured it way something on the SD (but really it was low battery, I didn't know how much it eats them) so i formatted it and attempted to put the same firmware on it and it would update then the boot screen came on and it just freezes from there....after awhile of that I tried a few other versions and it would get past boot screen and say "Patch Error." So (for some reason) I thought I should clean my PC and after re-downloading the firmware its right back to being stuck on the boot screen...Could this possibly be from something wrong with the SD I'm using (I'm using SD not SDHC)?
Any help will be much appreciated cuz I've been talking to e.s.c about this all morning and we cant figure out what the issue could be.

b4by f4c3 wrote:

So I recently got a GP2X and it came with firmware 3.0 & after using it for awhile the screen started to glitch so i figured it way something on the SD (but really it was low battery, I didn't know how much it eats them) so i formatted it and attempted to put the same firmware on it and it would update then the boot screen came on and it just freezes from there....after awhile of that I tried a few other versions and it would get past boot screen and say "Patch Error." So (for some reason) I thought I should clean my PC and after re-downloading the firmware its right back to being stuck on the boot screen...Could this possibly be from something wrong with the SD I'm using (I'm using SD not SDHC)?
Any help will be much appreciated cuz I've been talking to e.s.c about this all morning and we cant figure out what the issue could be.

Also im reformatting the SD everytime I put a different version of the firmware just to be safe

http://www.distant-earth.com/gp2x/2005/ … gp2xs.html