@sandneil: Beepola was made for Windows, so we can't really complain it doesn't work perfectly on another OS. And I hope pulseaudio is not considered vital because it seriously sucks!

Pulseaudio is not a great software, it burn a lot of cycle just running, I think it is not a good code. But at the same time I don't had a working alsa which accept multiple audio client at the same time. I know alsa is able to do it, but by default I was not able to make it works. And the doc is not simple...

Today, I think on linux you have to use :
- pulseAudio for desktop use
- jack if you want to use a low latency apps and you want to plug sound for one app to another, I don't know if it is compatible with a web browser, or wine, but most audio apps should be able to work with it ;
- alsa if every other thing fail wink

So I don't know for the future, I love alsa, it's just a lib with a bunch of kernel modu'e, but it is not rightly configured on the desktop ( debian ) to be able to run a multiple apps configuration...

yoyz2k wrote:

But at the same time I don't had a working alsa which accept multiple audio client at the same time.

what do you mean by that?

What i mean is :
- when I use a straight alsa configuration, I have no lag, but only one apps is able to use the audio card ;

So this configuration sucks in 2016 smile
But I know people are able to use alsa with a dmix plugin and this people are able to use multiple apps without pulseaudio. So it's possible, I'm not able to use it. I may be a dump alsa guy, which don't know how to configure a alsa linux setup. I just know it's possible.

unless you use digital output or run distro from previous decade, it should work fine, no need to configure.  dmix was enabled in alsa...  10 years ago?

what's your hardware?

Nothing about hardware I think in my case.
IMHO, it's only kernel related and packaging.
I use a hp laptop pavillon g6 amd 2 core with 4g of ram with debian unstable with the lastest kernel available.
I've switch to fedora 25 this week because I'd like to have a distro oriented desktop not a custom fluxbox wm anymore.

well I have similar setup:
Core2 Duo laptop 4GB RAM debian unstable with latest kernel, openbox wm.

Wahoo, so it's only me i think...

yoyz2k wrote:

What i mean is :
- when I use a straight alsa configuration, I have no lag, but only one apps is able to use the audio card

hold on.
are you talking about music production/audio recording apps? if so, in most cases you will need jack (but not pulseaudio!).
but if you simply can't hear playback from mp3, youtube, video at the same time (dmix) - there is something wrong with your setup.

I was not able to watch youtube and launch another audio apps at the same time ( both alsa client ).
If I use on this setup two audio jack compatible apps it works.
So seem to me a dmix problem, but it was a really modified debian with a lot of tweak, so I think I have just broke the alsa configuration file...

you could  try to reinstall alsa but anyway I hope you are happy with fedora.

garvalf wrote:

@mt12345 All those differences between distributions... that's odd. On a quite high end computer running linux mint, beepola has the glitches. I'll have a look at linuxbbq or a regular debian distribution, thanks!

I think I've found a solution, it seems if I run JACK, with pulseaudio bridged to jack, I don't have this sound problem. So I think I'll be able to work again on Beepola!

First thing I always do is disable/unistall pulseaudio. No idea why I would want to use pulseaudio in the first place, always just gave me issues.
I am now running Ubuntu Studio on an old eeepc (I think a 1000 series) and it runs ok, apart from the really horrible latency (anything below 512 samples will give me lots of xruns) even after running RTIRQ. But apart fromt that it works fine for the things I need to do with it.

People keep telling me to install Arch, which is a bit of work... so I never really get to try that. But a lot of people swear by it, and it has the advantage of not coming with a lot of useless stuff you don't want installed by default.

For all you pulseaudio haters out there (so, myself included, as well as pretty much any other Linux musician I know) I have some bad news: Starting with the upcoming ESR, Firefox will depend on pulseaudio. Not sure how to deal with this, things are looking pretty bleak as far as browser alternatives are concerned. Palemoon is build on legacy code, so probably not exactly secure, and Chromium is even slower than FF from what I hear, plus it doesn't have a good mechanism for selectively blocking scripts.

yeah, the Red Hat / Lennart Poettering conspiracy (pulseaudio, systemd...) is slowing tainting and destroying the free software / unix ecosystem, piece by piece sad

rumpelfilter wrote:

First thing I always do is disable/unistall pulseaudio. No idea why I would want to use pulseaudio in the first place

maybe to record playback in audacity without jack (eg. sampling from youtube clips)