I want to use my midi-keyboard to play my game boy like a synthesizer; kind of what the usb-keyboard-mod does, but without any modding.

I have an arduinoboy, a midi-keyboard and a DMG that runs LSDj. I tried connecting the MIDI-Keyboard to the arduinoboy's MIDI-IN and setting LSDj to keybd-mode, but that doesnt seem to work. whats more, the arduinoboy's LEDs dont show any response, regardless of any modus button pressing on the arduinoboy  - if I use MIDI-sync, it works fine, with the LEDs blinking away, doing different patterns when switching modes on the arduinoboy.

I already did a cm.o- and google-search, but to no avail.
I would really appreciate it if you could give me any hints, or tell me wether this works at all.
thanks in advance!

Last edited by Rynnon (March 4, 2013 5:34 pm)

Use mGB to play gameboy as synth, not LSDJ. I've not used it myslef but check here for all the info you need. Or search cm.o for mGB.

thanks! didnt know about mGB.

flashed mGB onto my cartridge just now, but there still is no sound. any ideas?


.......

this is the kind of thing that made me pick up the bass. you just plug it in, pluck it and thats it.

Last edited by Rynnon (March 2, 2013 1:20 pm)

Is your arduinoboy in the correct mode? Are it's leds responding to midi signals?

ashimoke wrote:

Is your arduinoboy in the correct mode? Are it's leds responding to midi signals?

I tried all modes on the arduinoboy. And no, the LEDs dont respond at all, they only flash when I switch the modes.
I also tried both MIDI-ports on the arduinoboy, again with all modes, just to be sure.

Midi channel setting of your midi keyboard? You should get sound with channel 1-5.

ashimoke wrote:

Midi channel setting of your midi keyboard? You should get sound with channel 1-5.

yeah, i read about that before ... i dont think midi channel setting is even possible with my keyboard, its as bare bones as it gets (m-audio keystation 49e, if that information is helpful); never set a channel anyway. i will look it up in the manual, though.

If you have a real cheap'n shitty midi keyboard, they won't work with everything. This might be the case. I'm talking from experience here.

I wouldn't say m-audio keystation is THAT shitty.

You can set the channel, check manual online.

ashimoke wrote:

I wouldn't say m-audio keystation is THAT shitty.

You can set the channel, check manual online.

There was indeed an option to set the channel, which I did just now (to channel 1); I dont know which channel it was set to before. It still didnt work, though.


Glitch Militia wrote:

If you have a real cheap'n shitty midi keyboard, they won't work with everything. This might be the case. I'm talking from experience here.

It works perfectly fine with ableton and my midi-interface-soundcard, so it cant be that bad.

Last edited by Rynnon (March 4, 2013 5:15 pm)

This might be a silly suggestion but it's worth a shot, because this definitely confused me for a bit. Make sure your keyboard's range or octave settings is within the Game Boy's range. With LSDJ in Keyboard mode, some of the "notes" actually send commands to LSDJ such as changing instruments, tables, etc. And obviously if the keys are out of the range of the notes the Game Boy can play, you won't hear anything. Give it a shot!

chipocrite wrote:

This might be a silly suggestion but it's worth a shot, because this definitely confused me for a bit. Make sure your keyboard's range or octave settings is within the Game Boy's range. With LSDJ in Keyboard mode, some of the "notes" actually send commands to LSDJ such as changing instruments, tables, etc. And obviously if the keys are out of the range of the notes the Game Boy can play, you won't hear anything. Give it a shot!

Thanks, I already tested it with all octaves between C1 and C4; right now I try to make it work with mGB, trying out different octaves as well. The silence persists >: [

Last edited by Rynnon (March 4, 2013 5:31 pm)

Can you get mGB work with Ableton?

i always had a problem trying to do this plugging direct from my korg midi keyboard to the arduinoboy. But once i do it from the korg to me soundcard to arduinooy it works fine. which is okay because im generally using it with ableton anyhow.

Sorry to necrobump this thread, but I'm having the exact same problems as OP with the arduinoboy I just built. The leds run through the startup sequence just fine and I can switch modes with the pushbutton, but no matter what I do I cannot get any midi activity in or out. The status led does not blink when I send the aboy midi notes. I'm trying it with both my rockband midi keytar as well as one of those cheapie usb->midi cables. Both of those methods of midi output work fine with my FB-01.

Anyone have any ideas? I'd love to be able to get this puppy working.

catskull wrote:

Sorry to necrobump this thread, but I'm having the exact same problems as OP with the arduinoboy I just built. The leds run through the startup sequence just fine and I can switch modes with the pushbutton, but no matter what I do I cannot get any midi activity in or out. The status led does not blink when I send the aboy midi notes. I'm trying it with both my rockband midi keytar as well as one of those cheapie usb->midi cables. Both of those methods of midi output work fine with my FB-01.

Anyone have any ideas? I'd love to be able to get this puppy working.

How is your optocoupler wired up?