Cool, thanks for the info!

I just stumbled on this after reading that thread from 2011. This program is really cool; it'll just save me some time oppose to just punching everything in manually hahaha.

Great stuff!!

it looks interesting. What is this srm feature? I've seen it's supposed to be used in SNES emulators, but I guess this srm is for some gameboy emulators?

Is there supposed to be a way to remove a song from the .sav in lsmc? I would have thought something along the lines of right-click 'remove'. Am i just missing it?

Oh shit! I just saw this like "Oh man, that looks helpfu- ...Alex?" haha. Whatup yo??

error wrote:

Is there supposed to be a way to remove a song from the .sav in lsmc? I would have thought something along the lines of right-click 'remove'. Am i just missing it?

Haha oh wow, you know what? There isn't. But that's a really good idea. That'll go in the next release.

EvilWezil wrote:

Oh shit! I just saw this like "Oh man, that looks helpfu- ...Alex?" haha. Whatup yo??

Haha hello!

Running into a bit of trouble getting this working on OSX El Capitan. Firstly, a couple of the dependencies seemed to be out of date, so I installed them manually. Now when I go to build I'm getting hit with a different error. Probably something stupid I'm missing.

Raised the issue on Github here - https://github.com/alexras/lsmc/issues/14 - but not sure how active the project is at the minute, so if anybody has insight that would be grand.

Did you install Python 2.7?

Sorry to hear you're having trouble. I've replied to the GitHub issue; hopefully we can get you unstuck.

Awesome, thanks. I'll take it over there!

@herr_prof - yup. Python 2.7 is installed; the folders that it's looking for in /usr/lib etc don't appear to be there though.

Ive seen people complain about 2.7 in other projects and they were told to try reinstalling python.

herr_prof wrote:

Ive seen people complain about 2.7 in other projects and they were told to try reinstalling python.

Yeah. There was something off with the wxPython install on El Capitan. I reinstalled via Python and updated the dependancy location (thanks to Alextras), and got it installed. Running into another issue when running the actual app itself, but it's (hopefully) unrelated.

I have el capitan as well and the LSMC.app runs fine, but when i open a sav file nothing happens...

I have el capitan as well and the LSMC.app runs fine, but when i open a sav file nothing happens...

This is the result i get from console log running both on osx or windows in VM:

179
Traceback (most recent call last):
  File "event_handlers.pyc", line 21, in ok_handler
  File "/Volumes/MAC HD 2/Music Work 2016/LSMC.app/Contents/Resources/LSMC", line 73, in set_sav
  File "ProjectsWindow.pyc", line 121, in handle_sav_loaded
  File "pylsdj/savfile.pyc", line 210, in project_list
  File "pylsdj/savfile.pyc", line 53, in __getitem__
  File "pylsdj/savfile.pyc", line 92, in _read_project
  File "pylsdj/blockutils.pyc", line 66, in read
  File "pylsdj/filepack.pyc", line 242, in merge
KeyError: 179

Traceback (most recent call last):
  File "event_handlers.pyc", line 29, in open_sav
  File "utils.pyc", line 84, in file_dialog
  File "event_handlers.pyc", line 26, in ok_handler
  File "utils.pyc", line 36, in show_error_dialog
  File "wx/_windows.pyc", line 3631, in __init__
TypeError: String or Unicode type required

EDIT2:

seems that one certain .sav files manage to load something in LSMC.app i am unable to really tell the difference between the sav files that do load and the ones that don't... the only important difference as far as im concerned is that the ones that do are not the ones that i want to use LSMC for.

Hoping there's an easy fix for this

Last edited by theskyis256k (May 6, 2016 1:52 pm)