turned on my gp2x after months of non-use, and the screen appears to have a fault; namely, there is a half inch white band down the right hand side, the image is pushed a half inch to the left and the screen image wobbles / flickers every few seconds.

I havent dropped the unit, fried the voltage regulator or bricked the unit via firmware updates, the model is an f-200.

Anyone know what might be causing this, commong gp2x screen issues or of any compatible screens that I could swap it out for?

Pissing me off as I just got my piggy to midi back after years and was planning on using the gp2x as my main sequencer..

If you've got nothing to lose.

i have a dead (bad sd slot) f200 that you could have pretty much just for shipping charges if you want.. screen still works great & buttons are all in good shape too

e.s.c. wrote:

i have a dead (bad sd slot) f200 that you could have pretty much just for shipping charges if you want.. screen still works great & buttons are all in good shape too

Does that offer extend to me as well? smile

Yes please!

catskull wrote:
e.s.c. wrote:

i have a dead (bad sd slot) f200 that you could have pretty much just for shipping charges if you want.. screen still works great & buttons are all in good shape too

Does that offer extend to me as well? smile

Ima go with no wink

catskull wrote:
e.s.c. wrote:

i have a dead (bad sd slot) f200 that you could have pretty much just for shipping charges if you want.. screen still works great & buttons are all in good shape too

Does that offer extend to me as well? smile

domu mentioned it first, so they get first crack.. if they opt out because of shipping cost (which i'll look up later today), then sure.. not sure how much it'll cost to ship to the UK, but it's probably pretty high because shipping prices have gone up a lot the last few years..on the other hand, a gp2x doesn't weigh much and its small, so it might not be as bad as i'm thinking

I look forward to it e.s.c!

i'm just glad that someone will be able to use the parts from it, it's just been sitting in a box since the sd slot died two years ago