France (au milieu)

well 6 DMGs for 2beat lines and a bass (sometimes on 2 instruments and a table!! yeaha!!) would be... how to say... mostly exagerated...

what I truly love in chipmusic stuff is walking/sitting on with 1DMG in its Pikachu bag, a head lamp when it's too dark and cheap headphones... and throw some fat sound with it smile

i'm a simple bass-man...

Last edited by Sesska (Jul 18, 2014 1:16 pm)

Sesska wrote:

1.3version is the way to go ... ?

Sesska wrote:

1.7 is the way to go.

you do defend your stuff very, very well wink

just trying to be helpful and answer your questions.

France (au milieu)

no sarcasm, you truly did!



Beta 4 is now available:

When installing over a previous beta, hold SELECT during startup until the boot logo appears.
Fixed bugs:

- Panning on R
- Sync
- Step pause display
- Pattern length display

There's a demo ROM, too: Limitations of the demo:

- No save function
- No song playback
- No short envelopes

Ohio, USA

16 wave forms? Variable pattern length? IT'S EVERYTHING I'VE EVER HOPED FOR IN LIFE (I'm a little late on finding out about this update, clearly)!

Wholesome Family Music wrote:

16 wave forms? Variable pattern length? IT'S EVERYTHING I'VE EVER HOPED FOR IN LIFE (I'm a little late on finding out about this update, clearly)!

OK then, big guy


thanks for the great work on this update oliver.

one technical question about updating this beta on mavericks.
when sending the file is finished and done is stated on terminal, the GB screen goes blank and freezes.

is that something specific to this beta or anything you could know what to do against?
or am i doing something wrong?

update: I also tried several types of cables that have worked before and all combinations with mavericks (mac) and windows xp. Especially the xp setup has always worked perfectly on upgrades like that, but somehow this doesn't. could it be that i am trying to put nl17b04 on an nl161?

update 2: now i tried to flash nl17 to an nl163 cart and the same happened. had to drop back to nl16 due to the same crash. i knew mavericks sucked, but mavericks over nanoloop is something we cannot have smile

any help would be hugely appreciated.

Last edited by the mist toggles (Jul 24, 2014 6:11 pm)

the mist toggles wrote:

when sending the file is finished and done is stated on terminal, the GB screen goes blank and freezes.

If it crashes, that means that 64k have been received but data are corrupt. The reason could be a broken cable or a bad connection, with an intact clock line and disconnected data line. Or other data have been received before or during the transfer, for example because some other program sends MIDI data.

If I understand correctly, it didn't work under XP either? Your post also seems to imply it was a Mavericks specific issue, so I'm not sure what you have tried and what not.
I just re-downloaded it and it worked fine on OS X 10.6.

Be sure to hold SELECT until the rhomb boot logo appears, then press SELECT + START so that the "n" appears below the logo. Generally keep the order of steps as shown here:
If, for example, you first press select + start and then plug the cable and send the command, it may receive a few bytes of other data / noise and save them as part of the update even before the transfer starts.

Also be sure to plug the adaptor with the right orientation:


thanks for the help and support oliver.

strange but good news.
it worked.
i had followed the procedure the right way, each time.

but now i tried yet another usb adaptor from those i have and it happened to be the right one.
i guess mavericks is a bit more picky than the previous mac os. didn't try win xp yet.

first moments with nl1.7 are fun. great work!!


On OS X, it sometimes just hangs. It seems to work, but in the end no data were transferred. The only thing that helps reliably is to reboot the computer.


Love it.
But - I'm getting a really annoying sound when using wavetables on S-channel. Like a narrow pulse after the envelope finishes.
When only using the S-channel it's faint- fairly ok. But as soon as I trigger something on any other channel the pulse gets really loud. Quite annoying!

Also, step pauses behaves strangely with less steps than 16.
(Strangely but ... very useful! wink)

Last edited by _-_- (Jul 31, 2014 12:55 pm)


Version 1.7.0 is now available for download:

nanoloop 1.7.0 update ROM (zip files at the bottom of the page)

New in this version:

- Soft pulse
- Adjustable tick frequency

Last edited by oliver (Jul 31, 2014 3:45 pm)


Ahh wow! So many new things!

Last edited by _-_- (Jul 31, 2014 9:34 pm)


1.7 is fantastic, thanks Oliver \m/


Here (or mp3) is the wavetable noise I was writing about earlier. So at first it's not too bad, but once I trigger something on noise/pulse channels it's really loud. It's very annoying to me, since I want to make really short percussive sounds with wavetables. sad


so pumped for 2.7. i just need to get my cart working again.