Hi everybody

I´ve got a Thursday Customs Arduinoboy and I´ve started using my DMG to play live with my band. For that, I´m currently using my Microkorg MIDI keyboard, that I plug via MIDI cable to the Arduinoboy. Although mGB works fine, I´ve been trying to configure LSDJ to work with my MIDI keyboard.

I know that it exists a keyboard mode that is originally conceived for using it with old PS/2 PC keyboards, but it looks like some people is using this mode to control a MIDI keyboard as well. As an example, I´ve saw this guy liamgouldy on youtube:

https://www.youtube.com/watch?v=qeRKhU0vp3c

I´ve been trying to do what he does, but I only get the same flat note when I hit the no matter what key on the keyboard. Does someone know what I´m doing wrong?

Sorry for my english smile

Hey, I'm not so dense, I figured this out!

Firstly make sure your Arduinoboy is set to LSDJ keyboard mode and LSDJ is set to Keyboard Sync.

Next, the list of keyboard commands from here https://github.com/trash80/arduinoboy#m … board-mode (edited, thanks herr_prof!)

LSDJ Keyboard Mode:
36 - C-1 Mute Pu1 Off/On
37 - C#1 Mute Pu2 Off/On
38 - D-1 Mute Wav Off/On
39 - D#1 Mute Noi Off/On
40 - E-1 Livemode Cue Sequence
41 - F-1 Livemode Cursor Up
42 - F#1 Livemode Cursor Down
43 - G-1 Livemode Cursor Left
44 - G#1 Livemode Cursor Right
45 - A-1 Table Up
46 - A#1 Table Down
47 - B-1 Cue Table
48 - C-2 to C-8 Notes!
Program Change to select from instrument table
Default Midi channel is 16. You can change in the top of the main source file in the archive.

So you need to set your MIDI controller to channel 16 for this to work, then select an instrument using Program Change.
Make sure the channel has a blank chain in it and then press play. You should be good to go.

Last edited by urbster1 (Jun 16, 2017 7:29 pm)

I am having the same issue as lambdata. I have LSDJ in keyboard mode, Arduinoboy is set to keyboard mode, M-U-T-E functions are working but the Gameboy only plays F#6 no matter what note I send. Help??

jonstapes wrote:

I am having the same issue as lambdata. I have LSDJ in keyboard mode, Arduinoboy is set to keyboard mode, M-U-T-E functions are working but the Gameboy only plays F#6 no matter what note I send. Help??

Does your arduinoboy work with any other modes?

I know that I´m very late, but a ton of thanks to @urbster1 for his tip about the midi channel no 16. In fact, that´s what I was doing wrong. After setting channel 16 in your MIDI keyboard the only thing you need is to create some instruments and put them in the phase page. Then you´re ready to go.

hey no problem, glad i could help smile

driveby post: the link above has been changed:
https://github.com/trash80/arduinoboy#m … board-mode

Hi
Sorry to use this post, but i'm actually trying to use lsdj on my gameboy with a classic midi Keyboard.
The first personne on the post said that it use the microkorg with an ardunoboy to play lsdj on live.
I have done lots of test but i didn't succeed .
Do you know whitch mode on the Ardunoboy and witch mode in lsdj

Thank

mixmax wrote:

Do you know whitch mode on the Ardunoboy and witch mode in lsdj

yes, my post above details everything you need.
put LSDJ and Arduinoboy in KEYBD mode, and put your MicroKorg to channel 16, then use Program Change to select an instrument. you need to have a blank phrase set up in order to play notes as well

Last edited by urbster1 (Jun 16, 2017 7:30 pm)

Hi Thank you for the answer.

I didnt have a microkorg i have a arturia keystep but i have understand the idea.
I hope i could do it work tomorrow

Thank you again