Offline

Is Pulseaudio installed on your system? I know LGPT can make trouble without it.

Offline
France Eure Et Loire

Now it is installed, I don't know if it was but I did it. But the problem is the same... sound is still horrible...

it's hard because I have to start pi boy, quit emulation station for have the terminal, then plug usb adaptor with ethernet + keyboard, and type commands by hand. I have to figure how connect to ssh on it

Last edited by MazHoot (Jan 13, 2021 9:20 pm)

Offline

Check this article
https://retropie.org.uk/docs/SSH/

Offline
France Eure Et Loire

I made sudo apt-get update and sudo apt-get upgrade and now, sound on LGPT is ok. But, the screen become not good. It's like 16/9 and my is 4/4. I can't start raspi-config it says command not found...

Normally I think I can edit config.txt for resolve this, but the config.txt is the same than before (I made a save of the previous one and it seems to be exactly the same and screen width and hight are here so it seems like it don't read config.txt...

emulationstation is in the good format and emulators too, but native application and terminal are bad displayed. This is the configs at the end of config.txt :

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
gpu_mem_256=128
gpu_mem_512=256
gpu_mem_1024=256
overscan_scale=1
# hdmi_force_hotplug=1

# hdmi_group=2

# hdmi_mode=87

# hdmi_cvt=640 480 60 1 0 0 0

# disable_overscan=1

# avoid_warnings=1
dtparam=audio=on
display_rotate=3
dtoverlay=mzdpi6
gpio=18=op,dh,pd
#gpio=0-9=a2
#gpio=12-17=a2
#gpio=20-25=a2
framebuffer_width=480
framebuffer_height=320
enable_dpi_lcd=1
display_default_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x07f006
hdmi_timings=320 0 28 18 28 480 0 2 2 8 0 0 0 60 0 32000000 1
audio_pwm_mode=1

Offline
Unsubscribe

Maybe you should try setting to to a hdmi mode 1 or 2, so its at the 4:3 resolution? then full screen should fil the entire screen

Offline
France Eure Et Loire

I finally get it working, if someone come here and have similar problems, installing pixel (lxde for retropie) is the way to go. After doing that, all became easyer, I saw the error messages, can manage boot in autostart.sh (have to write : startx yourfile.sh instead of emulationstation)

Installing raspbian without retropie didn't work, even by using video driver which is in overlay folder of boot. So keeping retropie but adding pixel was the solution as retropie can understand that, and can understand that you want to start it instead of buggy emulationstation

I played with frame_width, fame_high for have good screen (not too small) and a little (not too much) with overscan_top/left

the sound have crackling/poping, like have raspis... but It's much better that at the beginning, it was really worse at first...

Now If I want better sound I have to figure out how use an external soundcard and be recognized. Both my ur242 and zoomH4n are not recognized, on the pi boy or on my other raspberry pi, same problem.

Last edited by MazHoot (Yesterday 12:33 pm)