Hey guys,

I recently picked up a pretty dusty Sears 2600 from a thrift store, and I've had some issues using Synthcart with it. When turned on in a postion with beatbox active, the cart starts with the beatbox started and the right controller is otherwise non-responsive. With the beatbox not active, the right controller does nothing. The left controller seems to work fully.

In the options menu, only the top row of buttons work on the right controller, and the left controller works except that the Arp pattern defaults back to mix if the button for another option isn't being held.

I'm wondering where the fault for this malfunction lies. Unfortunately, my troubleshooting capabilities are pretty slim; I only have this console and a copy of Crystal Castles that seems to work fine with the joystick controller. Do these issues sound like a problem with the console or the cart? I've already had to fix a switch, so it isn't an entirely perfect system.

My copy of Crystal Castles also seems to fit into the slot more snugly and with a noticeable click, whereas Synthcart mostly just rests in the slot without any kind of click.

Does anybody have any experience troubleshooting these kinds of problems? Any help would be really really appreciated, thanks!

EDIT: Have tried multiple controllers, and the pins on the jack looks fine at a glance

Last edited by Fudgers (Jul 8, 2013 4:11 am)

Synthcart should function just like any other cart when inserting it.  That might give you somewhere to start.

I'm reasonably certain that the cart position is correct. I think my fears may have just been a product of being an Atari noob tongue

The controllers are just acting very strangely, as if a single button is held on, with the majority being only sometimes functional on the right controller. It's odd because if it was an issue with pins on the jack, then I would think that some buttons would be just totally non-functional, but the problems seem very dependent on the sound selection/menu from the cart.

I though someone else would get back to you pretty quick with useful ideas or info.

You said you already worked on a switch.  I would suggest yoi open it back up, visually make sure everything looks to be in good condition, with everything connected properly, and check stuff with a meter.

I wish I could help you in person, as the symptoms seem odd to me.  My first guess is either an issue with controllers/ports, or something related to the cartridge (not getting a good connection).  When you say you tried multiple controllers were they all keyboard controllers?  Which type of keyboard controllers did you use?  If you swap them does the one on the right still not do anything other than in options?    Did you try all 8 switch settings (you change them with the system turned on), and if so the only time you get anything related to the right controller is with beatbox settings when you powered it on (but no input), right?  We may need to look into how the controllers work (pinouts, etc).  I am a bit busy for the next couple days, but I will try to look this up for you, and I will mess with some of mine to see if I can replicate your problem if we don't find anything leading to a fix. Can you buy, borrow or steal another cartridge that uses both controller ports and test functionality that way?  What model is your 2600?

Opened the case back up and reflowed solder in a couple spots. Nothing seems noticeably cracked. Still need to go through thoroughly with the multimeter.

The controllers I've tried have been a joystick, two "basic programming" style keyboard controllers, and a video touch pad controller. All 8 directions and fire work on the joystick. I bought Star Raiders to test the keyboards and they seem alright with all the buttons working (i think. star raiders is a confusing game tongue).

Swapping controllers while the system is both on and off doesn't seem to help. All 8 switch settings are available. I get weirdly limited input on the right controller while the Lead or Pitfall is active. The lowest note remains active constantly and between 3-6 other buttons will play a different note while held and immediately return to the stuck note when released. On beatbox, the beatbox is started but no other input is available.

What model A26 do you have? On the sixers, the main board is connected to the switch board with a cable. The ribbon cable is a mylar laminate that can breakdown with age. 
Also the keypad controllers use all the pin of the port, each port has two 'POT pin ,5 and 9 for the Paddle controllers, that aren't used on the joystick controller. The KP controller is a simple 3x4 switch matrix, the game kernel sets one of the strobes, a column pin, and reads the row nibble, looking for a active high. Pins 1-4 are the rows and pins 5,6 and 9 are the columns.

Each 'pot' pin  has a RC network that is used as a simple A to D converter with the paddles.  The 'pot' in each paddle is coupled to a capacitor on the main board, forming an RC network. when the kernel wants to read the paddle, the pin is energized and the RC time constant is measured; I.E how long it takes to transition From 0 to 1. On the KP controller PCB there is a resistor in place of the pot, between each pot pin and pin 7, this is used to produce a very short RC time constant.

To my mind, you may either have a problem with the cart and port or the Right gameport.
.If it's a problem  with the right port, seeing as you swapped KPs it would be on the system board . Sounds like there may be a bridge, this would account for the constant note on. Or could be a bad cap for the pot pins.

If you had a bad cart port I wouldn't expect any cart to run, but other carts do fine. So there may be a problem with the cart itself. Is this a new synth cart? Try cleaning the contacts on the card edge .  Try to figure out why it doesn't seat in very well, could be something to do with the dust cover on the cart.
Good luck

Thanks for giving additional insight on this issue.  This is what I was hoping OP would get from someone with more familiarity with the 2600s.

OP said the controllers worked fine with Star Raiders (although now I see that it is only a single player game...).  Not sure if both ports are used at the same time for this game.

I had a question of my own, unrelated to the above issue, but I can't recall what.  Your reply did give me some ideas for a custom controller for constant notes.  Gotta love the drone.

Edit:  According to the manual for the game you "Plug the Video Touch Pad firmly into the RIGHT CONTROLLER jack", so if it were working properly with this game wouldn't that suggest it is not related to the controller port?  I don't have the game, and don't have my supercharger available to see what buttons are used.

Last edited by rygD (Jul 9, 2013 6:51 pm)

rygD wrote:

....

Edit:  According to the manual for the game you "Plug the Video Touch Pad firmly into the RIGHT CONTROLLER jack", so if it were working properly with this game wouldn't that suggest it is not related to the controller port?  I don't have the game, and don't have my supercharger available to see what buttons are used.

Yes, the best way to narrow down the possible causes is to substitute with know-good. So if swapping controllers while using the Synth cart didn't make a diff, probably not controllers. And if the right port works with a diff game, Star Raiders, then probably not the right port circuit. With the symptoms only with the Synth Cart, thinking that it has to do with the carts connections.

  But, all the above is based on allot of assumptions about what is working and not. From working on other systems I know that can lead you  "down a wrong path'. For instance we don't know for sure that Star Raiders handles the port the same way that the Synth Cart does, could be a timing issue with the pot pins and the frequency that the port is read. If there was access to a second Synth cart and/or second console we could pin it down faster.
Recently had a similar problem with a Game Gear handheld. Got a fixer upper from EBay for a project. Needed new caps before it would even stay on, then wouldn't boot the SMS cart connected with a Gear Master converter. This was the only kit I had, no GG cart to try; no second SMS cart and the converter was 'new' from EBay. Ended up getting more carts, both GG and SMS, and another Game Gear. After subing all combos, turned out to be the 'new' converter. The converter was not seating correctly in the GG, too thick.

Sometimes the best course is to list all the causes for a symptom and test them one by one, starting with the easiest.
The best case is to try the Synth Cart in a diff console, but in this case may not be possible. So the advice I can offer is to clean the contacts well, both the cart's and the console's, and determine why the cart is not seating with the same feel that the others have.
Here is the link to the controllers wiring
http://www.atariage.com/2600/archives/s … s_Low.html
Keep trying,
Yogi

Ahhh

Still chipping away at this puzzle, and I'm just as confused.

I got my hands on an Atari jr. that's only kind of functioning. It plays game and the controllers work, but the video is unclear and distorted at the edges. When my Synthcart is used in this system it doesn't seem to start at all. I just displays a colorful mess of a screen and produces no sound.

I'm genuinely at a loss now. Is my cart the problem?

Hey Fudgers, sorry I kind of dropped out for a while, got going on some other things.
Where do you stand? From your last post, sounds like an issue with your Synth Cart. If the Jr can run other carts even with the video problem, then it should run the Synth cart also. So that's 2 systems that are seem to have a problem with this cart.
Where did you get the Synth Cart? Is it old? If you got it recently from AA, I would contact them. Once or twice I had read problems plz have had with the Melody based cart. Not that the cart is a bad design but they may be more sensitive to a poor connection or weak power supply.
Anyway I hope you have already solve the problem,
Yogi

The synthcart I was using was brand new. I contacted AA and they were very gracious about letting me try another. I have, however, been out of town for a few weeks, but hopefully when I get back I can figure it out tongue

Fudgers, did you ever get to the bottom of this Synthcart problem?  I know this thread is ancient, but I just acquired a Synthcart on ebay that is doing almost EXACTLY what you described back in July 2013.  This is the only mention of the problem that I've been able find...