Online
Abandoned On Fire

(I sent this to the mailing list already, sorry if you've already seen this question)

I'm using Win32 piggy to send midi to mGB but I'm not getting any volume control other than envelope.

I know mGB responds to velocity, I had it hooked up to an external controller for a while.  The volume parameter in the the piggy midi instrument screen isn't doing anything for me.

Does piggy send velocity?  Or, possibly, can I get mGB to respond to the volume info that piggy is sending?

Offline
Unsubscribe

iirc correct it sends max velocity. You can test this easily in a midi monitor though. I think vol doesnt work because MGB doesnt respond to the midi vol command (cc07).

Offline
IL, US

correct, sends max velocity and mGB doesn't use cc07 for vol
so you have to work around it..i usually split the mGB channels hard left and right for a little better volume control via mixer

Online
Abandoned On Fire

That's what I expected.  I guess it wouldn't make sense for the midi instrument screen to have a velocity parameter, that's something that would need to be a pattern command.

I can make do, no biggie for now.

Offline
Unsubscribe

You can easily do a velocity scaler or filter if you run the midi through your daw or midi tools on windows as well.

Online
Abandoned On Fire
herr_prof wrote:

You can easily do a velocity scaler or filter if you run the midi through your daw or midi tools on windows as well.

That's a good suggestion.  I'm already routing audio through Renoise's effects rack so I could easily setup up some midi-thru channels.

Offline
Unsubscribe

http://www.thepiz.org/plugins/?p=pizmidi

midiCCModulator - Use one CC to modulate another CC (or note velocity) in various ways: add/subtract/multiply/etc, plus logic gates (AND, NAND, XNOR, etc).

Might be the best, you can use a unused midi cc to give you vol capacity back per step.

Last edited by herr_prof (Jul 3, 2014 9:04 pm)

Offline

I have sucesfully send and record midi sending velocities using a VOLM00xx effect in every note, with xx from 00 to FF

not sure if that really sends the velocity or the midi volumen, maybe is not the standard but my daw get it as the velocity, maybe mGB dont do so

Last edited by r0lemusic (Jul 8, 2014 8:54 am)

Offline
Unsubscribe

its probably sending it as midi cc7, which is vol. I always understood that piggy just did max velocity but maybe I am mistaken.

Offline

yep ,rite I've just checked this,  I'm using openMPT and had checked by default the option of  "volume columm are note velocities"

so anyway using VOLM and some kind cc7 mapping may do the thing perfectly smile

Last edited by r0lemusic (Jul 8, 2014 3:14 pm)