Offline
detroit

can anyone explain to me why .sf2 files sound like such shit on piggy ? successfully ( generously using this word ) gotten files to work on my psp using the latest stable and ghetto builds but every file sounds like complete garbage. I'm not too gutted over this just incredibly curious.

edit: I've tried a few dozen different soundfonts

Last edited by barbeque (Dec 23, 2014 10:31 pm)

Offline
IL, US

most of the ones ive tried sound fine, been rocking a deathmetal guitar one a bunch... im guessing it must vary based on how the soundfont is made.. that being said, i have a few that straight up crash piggy if i try and use them (sucks, since i was psyched about the rhodes one)

Offline

Sound fonts were never the best on piggy TBH. I always had trouble with crashes too.

Offline

what do you call to sound garbage?

may be a problem on available memory?

I can say they sound all great on my PC (i cant talk about other platforms) where I had used soundfonts above 200mb

I had had some problems with multi layered but nothing I cant solve with Polyphone soundfont editor in specific ones

Another thing to take in count is to use some like volm0400 to fade note to avoid zero crossing, but that is the same with samples

Last edited by r0lemusic (Dec 27, 2014 12:00 am)

Offline
Hoping to FINISH asong foronce

Hmmm. This doesn't have anything to do w/ LGPT, but, for what its worth, I had my own soundfont issues in Caustic 3.1 recently. I tried using the .sf2 that comes with MIDI Voyager and it imports every single sample or set of samples from that font as short white noise clips with really short loop points, so they play through once then give out this really loud, ear-raping buzz once the loop gets hit :0 So yeah, its probably the soundfont that's causing the problems. Just to be safe, I would use small soundfonts with small samples considering Piggy was made for mobiles.

Offline
Unsubscribe

also piggy only supports the most basic soundfont stuff, ie keymaps and loop points. All those fancy filters and effects are disabled.