Hello you beautiful people!

I've made myself an Arduinoboy using the classic Instructables guide and Trash80's documentation (, but there's a couple of problems.

I've wired up the whole thing and now I'm trying to use it (with mGB first, after that with LSDJ), but it's not responding. The status led should light up when it receives MIDI data, right? Not happening at all. Also it won't connect to the editor in Max MSP.

It does cycle through the LED's when powering up, but that's it. Also, when changing modes with the button, the LED for the specific mode doesn't stay lit.

Anyone had similar problems and could help me out?

Last edited by W4LKR (Mar 25, 2019 5:08 pm)


Here's some pictures of the arduinoboy. Using a DMG-07 cable. I've removed my switch, because I used the one that always connects and disconnects when pushed, so the wrong one. I cycle through modes by briefly connecting the 2 wires where the switch should be.

Last edited by W4LKR (Mar 25, 2019 5:20 pm)

London, UK

I'm not much of an expert on building an arduinoboy specifically, but if it were me, I would reflow the solder on pin D12 as it doesn't look like a good joint - you  can see a lot of the pad.
It also doesn't appear to be connected to the resistor next to it at the moment? but that might be the photo.


Thanks for the replay! It check the joints and those seem to be ok. Also, if I put it in LSDJ Master mode it does pick up the tempo from LSDJ (by led's blinking). No blinking leds or anyhing when I'm sending midi to the arduino (mGB, sending to channel 1 through 5).

I think I did forget to connect the TX to the midi out, but that shouldn't have interfered with the midi in, right?

Damn I want this thing to work :'(

edIt: just to double check with someone. The midi connectors as in the picture here s from the back, right?()

Last edited by W4LKR (Mar 26, 2019 2:21 pm)

Geneva, NY

IIRC there was an issue in that initial schematic.... something got reversed. Try switching the pin connections? Like, it doesn't specify if you're looking at the front or back of the plug...

London, UK

I am pretty sure those are from the front of the MIDI plugs actually, so that would explain it.

I think they're standard MIDI connections, so you can check other schematics, am looking for one using the same opto coupler now....

Last edited by Duck (Mar 26, 2019 3:29 pm)

London, UK

I *think* the diagram is a bit confusing.
If you look here;

pin 2 (with the 220R resistor) is going to pin 4 on the MIDI plug, and pin 3 to pin 5 - as the diagram shows above...

The problem is most female MIDI connectors for attaching to a PCB/stripboard are the other way up - and it is  looking at the front of the front of the plug I think, so it is quite easy to get this the wrong way round (I remember it giving me a massive headache last time I made one) - it's easier to think of the pin numbers on the plug I think as these are easier to work out whichever way you look at it?

I would definitely treble check this with the schematic and this pic:

Last edited by Duck (Mar 26, 2019 3:39 pm)


So, I changed the wires on the midi ports around and now the Arduino seems to pick up some midi data. Still not working properly though.

I've put it in mGB mode (led fleshing from pin D8) and in Ableton i select my midi out, change around the midi channel from 1 to 5 (poly mode) and now when I send out midi the leds repond! (yaaaas). BUT, still no audio comming from mGB or anything. Any ideas?

Thanks so much for the help until now big_smile

EDIT: I've also noticed that in mGB, when I change stuff in Ableton (like the midi channel, or just hitting random notes), the settings in mGB are changing (like octave, pb range, sweep etc.). Maybe some info that might help.

Last edited by W4LKR (Mar 28, 2019 12:21 pm)

London, UK


is the link cable you used an official Nintendo one? If not, did you already check the plug with a multimeter to make sure which pins are attached to which colour wire?

although, if you're working from just that arduinoboy image, I guess you had to.....

Not sure what else this might be really as it sounds like it's working but not sending the correct MIDI data. (maybe triple-quadruple check all the soldering just for luck.)

Last edited by Duck (Mar 28, 2019 1:44 pm)

London, UK

<edit - actually, what I posted in this post not relevant!>

Last edited by Duck (Mar 28, 2019 1:43 pm)


Yes it's an official DMG-07 cable. Tomorrow I'll check the cable with a multimeter. Also used this next to the original schematic: Also going to change out the arduino nano with an uno, just to check if that might be the problem.

And if that all doesn't work, you might know someone who sells kits for this preferably in the EU?

London, UK

hmm, then I assume you probably have the cable right, but definitely worth checking just in case...

I wouldn't have thought the Uno/Nano switch will make any difference, but again, worth a go! sometimes stuff just starts working for reasons unknown.

not sure about kits in the EU atm - these guys are sold out:

not sure if there is anywhere else but Catskull int he US. I feel like you must be able to fix this though without resorting to a kit wink


Thanks for all the info. I'd also rather see it work without a kit though haha. Fingers crossed wink