Offline
France Eure Et Loire

Oh ok! I thought if I did that it would shutdown piggy just after it started. For my part I placed the command directly in autostart file which is like this :

@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@point-rpi
@./Desktop/lgpt/lgpt_DEB/bin/lgpt.rpi-exe

so I can add @shutdown -h now at the end? I will try that

For the screen width, according to the cash express close to my house, this video rca cable doesn't exist haha... I have to buy it on internet... the x2 option in config.xml don't work if it's enable piggy boot only in window and it's bigger than the screen size... Maybe this cable will be the solution, I hope. If not, it's playable like that, not optimum but ok.

EDIT : hum... that's what I thought I tested what I said and it just close raspi after piggy started... I have to try with an .sh file like what you did

Last edited by MazHoot (Dec 15, 2020 10:35 pm)

Offline
France Eure Et Loire

Now i'm using a .sh file like you where lgpt is successfuly started and where it's suppose to close after lgpt quit but it's not working I tryed

sudo shutdown -h now
sudo halt
sudo poweroff

none of that works

Offline
France Eure Et Loire

The strange thing is that the two commands works, but not if the both are here.

If I only shudown in shell script, removing the exec lgpt command, then it boot and shutdown, but if there is the exec command of lgpt just before, then it start lgpt automatically at startup, but it not shutdown when I close lgpt and it just back me to the desktop. It seems that shell doesn't understand that I quit lgpt?

I also tried with python script for close, and with exec sudo but it's the same :

pig.sh

#!/bin/sh
cd /home/pi/Desktop/lgpt/lgpt_DEB/bin
exec sudo ./lgpt.rpi-exe
cd /home/pi/.config/lxsession/LXDE-pi
sudo python shut.py

shut.py

#!/usr/bin/env python3

from subprocess import call
call("sudo shutdown -h now", shell=True)

Last edited by MazHoot (Dec 16, 2020 10:18 am)

Offline
Unsubscribe

Ah ive only done it from the terminal, maybe running it from the desktop overides the shutdown?

I hate linux!

Offline
France Eure Et Loire

"I hate linux" hahaha... I work on it every day hehe

I have my response! with help of raspberry community : https://www.raspberrypi.org/forums/view … 7#p1780427

I just had to remove the "exec" word and it works.

#!/bin/sh
cd /home/pi/Desktop/lgpt/lgpt_DEB/bin
sudo ./lgpt.rpi-exe
sudo shutdown -h now

I think it should work also without sudo in my case.
I made a video just for fun when I was happy with midi working on lgpt :

at the end you can see the screen size which should be better if it was a little bit biger. I wait the rca video cable for test with it. Normally i'm on the lowest resolution, and if I use the x2 trick in config.xml, it's bigger than the tv and display don't work.
https://www.youtube.com/watch?v=n7sUiQ3 … el=MazHoot

Last edited by MazHoot (Dec 16, 2020 2:03 pm)

Offline
Unsubscribe

Yea i think with my screen I had to use a custom screen out resolution! there are other screen mult values, so maybe try 3?

good loop!

Offline
France Eure Et Loire

I get all the most things working right, but I hear a small latency with midi. I use LGPT to drive genMDM (awesome!!) additionnaly with LGPT samples and the sound of sega genesis is a little too late (microseconds) compare to LGPT samples. I use audio output of raspberry pi because I can't get my UR242 soundcard working and because sound is ok for me. I use usb to midi cable for drive genMDM.

I saw on LGPT wiki this :

"MIDI Configuration

This setting is also W32 only. It can be use to delay the output of midi by a certain amount of milliseconds. For example, to delay it of 1 msecs:

<CONFIG>
  <MIDIDELAY value='1'/>
</CONFIG>

also note: Because MIDI on PC is a bitch to synchronise and that the ONLY system that kind of worked was, surprisingly, the old MMSYSTEM audio system, I've re-enabled it as an option. So, if you need good midi sync or good timing, you will NEED to use this. The latency isn't great but in our case it's not a problem. To enable the old ass audio system and enjoy pretty stable midi out, add an entry in the config.xml with <AUDIOAPI value='MMSYSTEM' />
"

This should work only on windows right? Not on pi... and even if it worked, I don't want to delay midi, I want to delay sample for it sounds at the same time as midi.

But I tried MIDIDELAY value="2" for see, I didn't notice any difference. I didn't tried MMSYSTEM because I understood that it's for sync and I don't want to sync anything it's only midi out notes, CCs and samples

For me that's really the ultimate config, and I will defintly use again genMDM with LGPT! (on lsdj it worked but it was too complicated)

Last edited by MazHoot (Dec 20, 2020 7:52 pm)