Offline
France Eure Et Loire

Hi, I just remembered last day that I had a raspberry pi and wanted to test LGPT on it (most for the midi possibilities...)

I followed the tutorial here : http://lgptpi.blogspot.com/p/instructio … pbian.html

I can start lgpt but the window is too small, I can't see nothing or with difficultly. With FULLSCREEN=YES it change nothing because, yea, it's on fullscreen, but, the size of the visual don't change, it's just a small window on center and black screen around it lol... (I use a TV I have only that for the hdmi display of my raspberry pi, I tryed on a computer screen with hdmi to vga adaptor but it don't work, display is not working)

On the tutorial there is something about a .xml configuration file but I downloaded only the build lgpt.rpi-exe (which seems to not be on the github link given on this tutorial). So I don't have a .xml file. The next step will be to configure a usb gamepad controller.

Last edited by MazHoot (Dec 11, 2020 4:13 pm)

Offline
France Eure Et Loire

After some tests, I changed the screen resolution in raspberry pi config, and it's quite better, not fabulous but I can see something.

If it can help someone, after downloading lgpt-rspi.exe you have to do chmod +x on the file, AND ALSO download debian raspberry pi project, and place lgpt-rspi.exe in the Bin folder. Because if not you will not have access to samples libraries.

But... For me, after that, I discovered I have NO SOUND AT ALL on my raspberry pi. I did all the apt-get install upgrades, installing pulse audio... (maybe I should not...) and I have no sound at all, with lgpt or with firefox or with vlc, HDMI or analog mode, nothing :-(

It don't work better with my UR242 usb audio interface (even if it's good recognized as I can see it when I right click on audio icon on up right corner.

Last edited by MazHoot (Dec 12, 2020 1:55 pm)

Offline
Unsubscribe

Which distro are you running? Ive had nothing but problems with anything but 32bit rasbian

One other thing is you should run it from the terminal not from the gui desktop. Fullscreen then should run at its native resolution.

For sound you might want to make sure you reinstall the alsa-sound package. Installing jack seems to get all the appropriate sound stuff working.

Offline
France Eure Et Loire

This is my raspberry version :

PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
VERSION_CODENAME=stretch
ID=raspbian
ID_LIKE=debian

For what you says about terminal, I only tried to run lgpt with the terminal, nothing else. The fullscreen don't change the size compare to not full screen mode, it just make black color around the window. But for now this is not my big problem. It's audio...

I tryed speaker-test -c2 -t wav but I hear nothing... in analog or hdmi mode.

I tryed reinstallation of qjackctl, pulseaudio, alsa but nothing change sad

I'm thinking about reinstall completly my raspberry pi :-( the strange thing is that I remember in the past, before make all these updates, it worked, I used it to watch movie the sound was ok (I think it was 1 or 2 years ago).

Last edited by MazHoot (Dec 13, 2020 11:45 am)

Offline
France Eure Et Loire

Oh!! I got sound!! With Kodi (I didn't reinstall my pi) ON HDMI. I have an audio file on desktop for testing. I tryed for the first time : right click, open with Kodi (it's a media app), it open kodi in fullscreen and there the sound works! That's the only way for know I can have sound (I can't leave Kodi without unplug raspberry power and replug it which make me very angry...)

The other times, I tryed to start my audio file with VLC wich not works. On youtube I have no sound too. I didn't try other methods.

On LGPT, I got these error message displayed several times in terminal after trying to play the demo song :

[email protected]:~/Desktop/lgpt/lgpt_DEB/bin $ sudo ./lgpt.rpi-exe

RtApiAlsa::callbackEvent: audio write error, No such process.
RtApiAlsa::callbackEvent: audio write error, No such device or address.
RtApiAlsa::callbackEvent: audio write error, Exec format error.
RtApiAlsa::callbackEvent: audio write error, Argument list too long.
RtApiAlsa::callbackEvent: audio write error, No such file or directory.

Last edited by MazHoot (Dec 13, 2020 12:25 pm)

Offline
Unsubscribe

is that the 32bit or the 64bit version of the os?

Offline
France Eure Et Loire
herr_prof wrote:

is that the 32bit or the 64bit version of the os?

It's 32bit

Offline
Unsubscribe

you might try reinstalling alsa?

Offline
France Eure Et Loire

Yes!! After reinstalling several times alsa, used different commands found on internet, finally I have sound, and sound on LGPT works too! Thank you!

Now, I must solve the fullscreen problem. I have found that if I change the resolution of raspi, I can have a better visual (bigger) but that's not good because it make the use of all other horrible when everything is too big.

My goal is to have lgpt launching automatically in fullscreen (and in big) when launching my raspberry pi, with my controller setting up and go! So at the end the screen for other use will not be a problem but until I still must configurate things, it's a problem.

How do you close LGPT when it's in fullscreen? ctrl + alt + supr, or echap do nothing

EDIT : i'm very stupid, I didn't thought about just go in main menu and click on exit in LGPT...

Last edited by MazHoot (Dec 14, 2020 8:45 pm)

Offline

@MazHoot does LGPT scale to the window if you resize it manually?

Offline
Unsubscribe

are you using HDMI? I always used the rca video out, so yea you might need to change the default resolution to something more 640ish

Offline
Unsubscribe

also maybe try screenmult

Offline
France Eure Et Loire

@cyberic :
I can't resize manually it don't work, the cursor don't transform to resizing tool.

@herr_prof:
On my Raspi I have only hdmi out. I can't use something else, which should be better.

EDIT : Ohh O.o! wait, I have an icon on mini jack output that seems to mean I can have video output too with minijack. I didn't know that! How use it? with a mini jack to rca + video cable (minijack to white, red and yellow)? I have to find one for test!

Last edited by MazHoot (Dec 15, 2020 3:27 pm)

Offline
Unsubscribe

Yea or setup the HDMI out to have a smaller resolution https://www.raspberrypi.org/documentati … t/video.md

Offline
France Eure Et Loire

I sucessfully start lgpt when starting raspberry pi with placing a command in /.config/lxsession/LXDE-pi/autostart

But how I can shutdown automatically rapspberry pi after quitting Lgpt?

Offline
Unsubscribe

So you can add a command that is like SHUTDOWN after the piggy command. Once pig ENDS it will then do the shutdown command, which will do all the nice disk unmountingstuff

This is from memory but I would actually run a pig.sh file in my autostart that was like

#!/bin/sh
cd /mnt/sd/apps/lgpt
exec ./lgpt.exe
shutdown -h now