I was looking forward to start rocking in HoustonTracker 2 today, but I got stuck on getting the sync to my PC working.

I have a TI83+ and gray Graph Link /w serial port. I'm on win7 64bit.
This is my cable:

In the TiLP settings I have selected GrayLink and TI83+.
When clicking Ready or DirList I get the error: "Msg: timeout occured while reading from the device. Cause: check that link cable is plugged and/or the calculator is ready."
Some times I get the error above with this text after: "The system cannot find the path specified".

Also when I start TiLP, my calculator freezes (the cursor stops blinking).
I tried all ports in the settings and only one causes the freezing - I guess this is the correct one.

The calculator can send/receive to another TI83+ without problems. I think I have missed something basic here.

Plz hlp! smile


Problem solved by using the TI Connect software.
TI Connect detects my cable as a Black cable. I was maybe wrong when trying GrayLink in TiLP.
Though I did try the BlackLink TiLP (with the drivers installed - BlackLink checkbox checked during installation).

Oh well, it works! Hope this can help somebody.

Nomad's Land

Glad you were able to solve this. I'll add a note to the HT2 manual.
And yes, that's indeed a BlackLink, not a GrayLink. Shame on me for not noticing earlier yikes

Btw, is a good place for technical questions regarding TI calcs.

Last edited by irrlichtproject (Oct 13, 2015 5:30 pm)


Thank you! I should probably have read the TiLP manual more carefully - the cable names should be explained there.
I will stick with TI Connect for now, but I like the command line mode of TiLP, so at some point I'll give it a try again.

Good tip about, I'll remember that.



I'm using the same cable, but on a Compaq Armada 1700 with Win98 SE and FastLink. I've had no issues. I am also using the same laptop, for transferring images from a GB camera with the Madcatz link cable.  Also DOS and OPL3 stuff. Obsolete FTW :-D