Offline
London, UK

I can't seem to get this to work with a home made MIDI cable. I have it wired up as below, and have checked with multimeter.... seems to have zero effect on anything whether I plug it into my audio interface and try and sync ableton OR into my drum machine.....

I wondered if it might be this:

"The current supplied by the GBA's link port does not quite match the MIDI specification (3.5 mA instead of 5 mA). So far, it worked with all devices tested but there may be devices that require full 5 mA."

but seems odd that I should own two things that object to the voltage when it sounds like it's uncommon.

Has anyone had issues getting this to work/could explain more clearly than the manual does how I am supposed to set off nanoloop so it should work?

I'm in the middle of building an arduinoboy to get round this (at least until I can get a USB midi dongle) but would be even better to only have to carry a MIDI cable with me if I could get

Offline
Lancashire,UK

set nanoloop into midi sync mode got to BPM change press a + b then hold B press select till a M appears under bpm value then make sure your cable is working (plug into midi IN) then once nanoloop is in midi mode press start and its should clock external gear to nanoloop, ive made this cable and i have  successfully synced a yamaha RX21 to nanoloop 2.7 and it works like a dream (if this is not the case try a different link cable im using a gamester link cable some third party cables might not work)

Offline
Lancashire,UK

.

Last edited by Dumbug (UK) (Mar 12, 2020 6:54 pm)

Offline
Lancashire,UK

i suspect that you already know the above id recommend trying a different cables entirely if it still doesn't work then it will probs be due too the midi device needing the full 5mA

Offline
London, UK

thanks.

having massive issues getting Nanoloop to sync to anything at all tbh- now trying with an arduinoboy with a similar lack of success!

possibly my drum machine wants 5v i guess. no idea whats up with the arduinoboy though

Offline
Sea of Souls

Have you tried connecting the ground pin? It is the third pin that is shaded in on the link port drawing, but not labelled.
Connect that to the center pin of your midi cable.

Offline
London, UK

thanks, that sounds like a very good idea! Will give it a try later.

Offline
London, UK

alas this did not solve things.
I have two GBAs, a teensy boy and a newly modified cable and I get absolutely no effect from any of it. Weird.

Offline
London, UK

I am right in thinking there are three sync modes aren't I? MIDI slave is first, showing nothing? It's not the same as "a"?

So confused as to why I can't get it working...

Offline
Sea of Souls

idk what options there are in software.
But my other suggestion is to swap In and Out on one end of your cable. You know how Rx goes to Tx and vice versa.