Anforium wrote:

Schism tracker is also in the repos, although I haven't spent much time with it.

I've never even tried to run it, but there's a linux version of Adlib Tracker

I can confirm these work great on Linux. There's also klystrack.

Some others that I play around with regularly:

- qtractor - an Audio/MIDI multi-track sequencer application. I really like this one, it's easy to use, looks great, and has support for plugins of various kinds for softsynths

- Carla - Audio plugin host (VST, LV2, LADSPA etc) from KXStudio

- DISTRHO - A bundle of VST and LV2 plugins, including dexed which is a FM synth and can be used to make chip-tune-ish sounds, as well as TAL noise maker which is also an awesome softsynth for this kind of stuff

- Helm - Another fav free software VST synth

- Munt - Emulator for the Roland MT-32 series synth

Last edited by witchspace (May 31, 2016 6:50 am)

*accidental double-post*

Last edited by witchspace (May 30, 2016 2:06 pm)

IceWolf wrote:

Hmm, I thought I read somwhere that milkytracker and something else can run in a framebuffer without X. Forget where I read that though...

in Schismtracker FAQ ?

I couldn't force FLStudio, MadTracker and Deflemask to work in Windows 10 but those apps work fine in Debian Linux via wine along with Reaper, Renoise, Cubase, Ableton, OpenMPT, Adlib2, PowerFM, YM2149 and, after increasing the buffer, FamiTracker.

Last edited by mt12345 (Dec 11, 2016 9:18 pm)

If you can give tips on how to use beepola with wine, it would be cool, because the sound gets corrupt very quickly (buffer problem I guess)

garvalf wrote:

If you can give tips on how to use beepola with wine, it would be cool, because the sound gets corrupt very quickly (buffer problem I guess)

need some demo songs to test

I have been running linux on my main music computer for some time. In the end I got a bit annoyed by several small things... which to be honest often aren't really linux's fault. For example my sound interface wouldn't work smoothly, but that was the fault of the computer's firewire chipset.
Anyway, I found audio distros to be a lot easier to deal with than regulars ones. I ran Ubuntu Studio with the added KX repos.

Last edited by rumpelfilter (Dec 11, 2016 7:12 pm)

I addded KX repos to Debian but after I installed wine-rt and all audio suff something went wrong,  I couldn't launch any window app and after reboot I couldn't even login to X.

KXStudio is based on ubuntu 14.04 (end of support next year?) but I want give AVLinux a try (Debian Testing build from 08.2016).

@garvalf

uninstall pulseaudio ?

@mt12345 No specific demo songs to show, it seems to have the problem on most songs. It plays well, and after 1 or 2 patterns the sound begins to go havoc. When I encountered this for the first time, I killed or removed pulseaudio and it seemed to do the job. But now even this isn't enough, I'm still getting the sound tearing. I'm using the kx repo as well, with a low latency kernel.

I mean there are no demo songs included and I couldn't find any songs to download.
Anyway Im gonna fresh install AVLinux or Ubuntu 16 +KX (tomorrow?).

Ok, i'll post one later. Btw sometimes the problem appears after more than 10 patterns. As soon as i stop and restart the replay, the sound is ok, and after 3-4 patterns problem appears again.

Is there such a thing as an ARM / Rpi based Vsti host availible? i dont want to run anything super complex, but want to host a few synths ive made using synthmaker / flowstone on a tiny standalone platform... Have seen a commercial thing called zynthian or something that does something similar but f*** that..

If the VSTis are compiled for Windows then you need to run them through Wine (and if they're made with Synthmaker, then they're 100% Windows). I did try to run Windows VSTs on Linux some time ago, and it went ok. But I didn't really try to make any music with it, nor do I remember how I did it (but I remember that I followed an online howto).
Also I think that even Linux VSTs might not work on a Raspberry PI, since it uses an ARM CPU and not Intel x86, so probably the VSTs would have to be compiled from source.

i knew i was dreaming too high; thanks anyway rumpelfilter!

@mt12345 : here is a beepola song which has the problem on Linux: https://drive.google.com/file/d/0B4klvq … sp=sharing

The tritone engine has the problem, but it's even worse if you shift the engine to Qchan, then slowdown is even more massive. Sometimes  (I mean, on some computers) there are slowdown, on others the sound is corrupt in a different way but it sounds bad anyway. I'm 100 % sure it's a buffer problem, but beepola doesn't allow to increase the buffer so I fear it's hopeless.

i knew i was dreaming too high; thanks anyway rumpelfilter!

I might be wrong though. Though VSTs have to be compiled for the OS they need to run in, this is a fact. Not sure about the architecture thing...
but I just found this: https://www.reddit.com/r/raspberry_pi/c … o_do_this/
might contain some info...